• Регистрация

1,096 вопросов

1,459 ответов

1,302 комментариев

8,780 пользователей

Добро пожаловать на Ubuntu Ответы, где вы можете задать вопросы и получить ответы от других пользователей сервиса.

E: Package 'libpng12-0' has no installation candidate

0 голосов

Я пытался установить WPS Office на свой ноут через Gdebi. У меня Ubuntu 16.10, x64, Gnome). Но выдает вот такое сообщение:

Dependency is not satisfiable: libpng12-0

После этого я пробовал поставить библиотеку, на которую ругалось:

sudo apt-get install libpng12-0

Но получил другую ошибку:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package libpng12-0 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
E: Package 'libpng12-0' has no installation candidate

Можете помочь? Как установить то, что мне надо?

Вопрос Sep 11 от kosmos Новичок (620 баллов) в категории Настольные системы
   

1 ответ

0 голосов

Мы vожете скачать собранный пакет libpng12-0 package здесь:

У меня была подобная проблема со сломанными зависимостями. Установка готового пакета помогла.

Ответ Sep 11 от and3001 Гуру (24,350 баллов)
...