• Регистрация

1,110 вопросов

1,478 ответов

1,315 комментариев

8,887 пользователей

Добро пожаловать на Ubuntu Ответы, где вы можете задать вопросы и получить ответы от других пользователей сервиса.

wine больше не поддерживает msi

0 голосов
Всем доброго времени суток
Сразу предупрежу что я не очень уверенный пользователь линукс и по тому история описанная мною ниже возможно имеет очень простое решение.
Давно я не использовал wine, а когда использовал - всё работало "на ура" ну или как минимум с пол пинка всё заводилось и устанавливалось
достаточно было лишь немного погуглить и решение приходило само собой, но вот недавно я решил создать свеженький префикс и наустанавливать всего
что необходимо для нормальной работы юнити (дотнет, дээкс9 и прочую чушь) но тут я столкнулся с непонятной мне непреодолимой силой.
А именно при попытке установке я получил предупреждение что не установлен windows installer, в списке winetricks я его не нашёл (возможно плохо искал)
ну да ладно, залез значит на сайт мелкософта и скачал на всякий случай 2 версии 3.1 и 4.5 под винэкспи и какой то там 1 под вин7
установил я 4.5 и в wincfg прописал msi. Ну думаю сейчас то всё заработает, но каково было моё удивление когда запустив
WINEARCH=win32 WINEPREFIX=~/wine/unity winetricks winxp dotnet20 через часик я наблюдал всю ту же картину подготовки к установке что и при запуске оной.

вывод консоли во время запуска примерно такой:
Executing w_do_call winxp
Executing load_winxp
Setting Windows version to winxp
Executing winetricks_early_wine regedit C:\windows\Temp\_winxp\set-winver.reg
Executing w_do_call dotnet20
Executing load_dotnet20
Executing w_do_call remove_mono
Executing load_remove_mono
------------------------------------------------------
Mono does not appear to be installed.
------------------------------------------------------
Executing w_do_call fontfix
Executing load_fontfix
Setting Windows version to win2k
Executing winetricks_early_wine regedit C:\windows\Temp\_dotnet20\set-winver.reg
Current wine does not have wine bug 30845, so not applying workaround
Executing wine dotnetfx.exe
fixme:advapi:DecryptFileA ("C:\\users\\pavel\\Temp\\IXP010.TMP\\", 00000000): stub
err:secur32:SECUR32_initSchannelSP TLS library not found, SSL connections will fail
fixme:advapi:LsaOpenPolicy ((null),0x33f2e4,0x00000001,0x33f2d0) stub
fixme:advapi:LsaClose (0xcafe) stub
fixme:sfc:SFC_3 0

а далее по мере продвижения бесконечно выполняющейся подготовки примерно раз в минуту появляется строка:

err:ole:CoGetClassObject no class object {000c101c-0000-0000-c000-000000000046} could be created for context 0x4

и таких разумеется через час на пол буфера консоли было
собственнно зависаний как установщика так и самой консоли разумеется нет, но и установка не продвигается как таковая - что меня жутко удивило
особенно когда я заметил что консоль не особо информативна на этот счёт - я и приуныл, гугляж в этот раз ничего не дал и весь день потерянняй в пустую
принёс осознание беспомощности, но и это ещё не всё так как я решил не сдаваться и добавить себе трудностей, чтобы было не столь скучно.

Через несколько минут я решил всё таки сделать как рекомендуют в загугленом и снёс (через purge разумеется) Wine 1.6 i386 поставив wine 1.4 i386 - и результат не замедлил себя ждать
ибо через пару минут всё тоже самое повторилось, приуныв я так же пробывал переставить и wine 1.7 i386 но уже из репозитория самого wine, но ничего не помогало.
К слову сказать та же ситуация или другими словами можно сказать примерно таже была с msxml6.

Ещё можно добавить то что я заметил из всего этого что при установки windows installer он формально завершает работу и окно то закрывается, но если был запуск в консоли - то там переход в интерактивный режим не происходит
что говорит мне о том что процесс продолжает работать, если вне консоли запускать то через ps видно что он продолжает по какой то причине работать.
Ну да суть не в этом, когда я пытаюсь насиловать префикс путём  WINEARCH=win32 WINEPREFIX=~/wine/unity wineboot -u он обновляет его, но если я до этого устанавливал
скажем msxml6 и потом прервал - то он запускает снова вечную установку.

Без указания префикса (в дефолтный .wine) я тоже пробовал результат тот же и чего я сделал вывод что с wine что-то не то просходит либо не здоровое, хотя странно что
гугл мало что дал, возможно я делаю что-то не то, что раньше проходило "на ура" а теперь поменяли.

Используется lubuntu 14.10 (ядро generic) переставлял: wine1.4:i386 wine1.6:i386  wine1.7:i386
Вопрос Aug 7, 2015 от pdragon Новичок (120 баллов) в категории Настольные системы
   

1 ответ

0 голосов
Из приведенных фактов сложно сказать в чем именно проблема. Можете какие то скриншоты показать? Так же вижу что wine ругался на отсутствие mono. Вы mono доставили?
Ответ Aug 7, 2015 от and3001 Гуру (25,060 баллов)
...