• Регистрация

1,096 вопросов

1,459 ответов

1,302 комментариев

8,780 пользователей

Добро пожаловать на Ubuntu Ответы, где вы можете задать вопросы и получить ответы от других пользователей сервиса.

Конфликт зависимостей при установке пакетов

+1 голос

Не могу установить обновления или программы из-за ошибок, в общем ссылающихся на нерешенные зависимости, система советует:

sudo apt-get install -f
вот последствия:
 
[sudo] password for cross: 
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Исправление зависимостей… Готово
Следующие пакеты устанавливались автоматически и больше не требуются:
  account-plugin-icons libatk-adaptor-data libclutter-gst-1.0-0 libcmis-0.2-2
  libcogl-pango0 libcogl9 libgrail5 libgwibber-gtk3 libgwibber3 libkms1
  libllvm3.1 libmusicbrainz5-0 libmx-1.0-2 libmx-bin libmx-common libnux-3.0-0
  libnux-3.0-common libpython3.2 libqpdf8 linux-headers-3.5.0-27
  linux-headers-3.5.0-27-generic python3-pyatspi2 python3-pycurl python3.2
  python3.2-minimal unity-lens-gwibber unity-scope-gdocs
Для их удаления используйте «apt-get autoremove».
Будут установлены следующие дополнительные пакеты:
  libwayland-client0 libwayland-cursor0 libwayland-server0
НОВЫЕ пакеты, которые будут установлены:
  libwayland-client0 libwayland-cursor0 libwayland-server0
обновлено 0, установлено 3 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.
не установлено до конца или удалено 8 пакетов.
Необходимо скачать 0 B/65,9 kB архивов.
После данной операции, объём занятого дискового пространства возрастёт на 257 kB.
Хотите продолжить [Д/н]?

Пишу "да":

(Чтение базы данных … на данный момент установлено 230058 файлов и каталогов.)
Распаковывается пакет libwayland-client0:amd64 (из файла …/libwayland-client0_1.2.1-1~r~gd_amd64.deb) …
dpkg: ошибка при обработке параметра /var/cache/apt/archives/libwayland-client0_1.2.1-1~r~gd_amd64.deb (--unpack):
 попытка перезаписать «/usr/lib/x86_64-linux-gnu/libwayland-client.so.0.1.0», который уже имеется в пакете libwayland0:amd64 1.0.5-0ubuntu1
Отчёты apport не записаны, так достигнут MaxReports
                                                   Распаковывается пакет libwayland-server0:amd64 (из файла …/libwayland-server0_1.2.1-1~r~gd_amd64.deb) …
dpkg: ошибка при обработке параметра /var/cache/apt/archives/libwayland-server0_1.2.1-1~r~gd_amd64.deb (--unpack):
 попытка перезаписать «/usr/lib/x86_64-linux-gnu/libwayland-server.so.0», который уже имеется в пакете libwayland0:amd64 1.0.5-0ubuntu1
Отчёты apport не записаны, так достигнут MaxReports
                                                   Распаковывается пакет libwayland-cursor0:amd64 (из файла …/libwayland-cursor0_1.2.1-1~r~gd_amd64.deb) …
dpkg: ошибка при обработке параметра /var/cache/apt/archives/libwayland-cursor0_1.2.1-1~r~gd_amd64.deb (--unpack):
 попытка перезаписать «/usr/lib/x86_64-linux-gnu/libwayland-cursor.so.0.0.0», который уже имеется в пакете libwayland0:amd64 1.0.5-0ubuntu1
Отчёты apport не записаны, так достигнут MaxReports
                                                   При обработке следующих пакетов произошли ошибки:
 /var/cache/apt/archives/libwayland-client0_1.2.1-1~r~gd_amd64.deb
 /var/cache/apt/archives/libwayland-server0_1.2.1-1~r~gd_amd64.deb
 /var/cache/apt/archives/libwayland-cursor0_1.2.1-1~r~gd_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Вопрос Oct 16, 2013 от cross Новичок (130 баллов) в категории Настольные системы
Редактирование Oct 16, 2013 от sir_mcnellan
   

1 ответ

+1 голос

Удалите  libwayland-client0_1.2.1-1~r~gd_amd64.deb:

sudo rm -v /var/cache/apt/archives/libwayland-client0_1.2.1-1~r~gd_amd64.deb 

Ответ Oct 16, 2013 от sir_mcnellan Ветеран (8,910 баллов)
...